Skip links

Security Buffer overflow, SAP security note 1414112

Description

A stack overwrite can be triggered in the SAP kernel. This stack overwrite can probably be remotely exploited in order to execute arbitrary code with the permissions of the kernel process. An attacker who exploits this might gain control over the SAP Web Application Server. In order to misuse this, the attacker needs to have a valid account in the SAP system. SAP systems with activated ICF services based on ITS are vulnerable.

Available fix and Supported packages

  • SAP_BASIS | 640 | 640
  • SAP_BASIS | 700 | 701
  • SAP KERNEL 6.40 32-BIT | SP312 | 000312
  • SAP KERNEL 6.40 32-BIT UNICODE | SP312 | 000312
  • SAP KERNEL 6.40 64-BIT | SP312 | 000312
  • SAP KERNEL 6.40 64-BIT UNICODE | SP312 | 000312
  • SAP KERNEL 6.40_EX2 32-BIT | SP312 | 000312
  • SAP KERNEL 6.40_EX2 32-BIT UC | SP312 | 000312
  • SAP KERNEL 6.40_EX2 64-BIT | SP312 | 000312
  • SAP KERNEL 6.40_EX2 64-BIT UC | SP312 | 000312
  • SAP KERNEL 7.00 32-BIT | SP235 | 000235
  • SAP KERNEL 7.00 32-BIT UNICODE | SP235 | 000235
  • SAP KERNEL 7.00 64-BIT | SP235 | 000235
  • SAP KERNEL 7.00 64-BIT UNICODE | SP235 | 000235
  • SAP KERNEL 7.01 32-BIT | SP072 | 000072
  • SAP KERNEL 7.01 32-BIT UNICODE | SP072 | 000072
  • SAP KERNEL 7.01 64-BIT | SP072 | 000072
  • SAP KERNEL 7.01 64-BIT UNICODE | SP072 | 000072

Affected component

    BC-FES-ITS
    SAP Internet Transaction Server

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/1414112

TAGS

#Security
#Buffer-overflow
#disp+work