Skip links

Code injection vulnerability in ECC and SAP R/3, SAP security note 1453655

Description

SAP R/3 4.6, Enterprise R/3 4.7,  ECC 5.00, ECC 6.00 – 6.04 contain code which allows to uncomment any commented ABAP program code. By this change a malicious user can therefore change the behavior of the system or can potentially escalate privileges by executing previously deactivated code without legitimate own credentials.

Available fix and Supported packages

  • SAP_HR | 46C | 46C
  • SAP_HR | 470 | 470
  • SAP_HR | 500 | 500
  • SAP_HR | 600 | 600
  • SAP_HR | 604 | 604
  • SAP_HRCDK | 470 | 470
  • SAP_HRCDK | 500 | 500
  • SAP_HRCDK | 600 | 600
  • SAP_HRCDK | 604 | 604
  • SAP_HR 46C | SAPKE46CG3 |
  • SAP_HRCDK 500 | SAPK-50074INSAPHRCDK |
  • SAP_HRCDK 604 | SAPK-60423INSAPHRCDK |
  • SAP_HRCDK 600 | SAPK-60057INSAPHRCDK |
  • SAP_HRCDK 470 | SAPK-470A8INSAPHRCDK |

Affected component

    PY-XX
    Payroll: General Parts

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/1453655

TAGS

#Backdoor
#injection
#run
#credentials
#SAP-R/3
#SAP-R/3-Enterprise
#&x00A0-&x00A0-ECC-5.00
#ECC-6.00—6.04-SAP_HR
#SAP_HRXX