Skip links

Vulnerability during dynamic function call without validatio, SAP security note 1471265

Description

Due to a vulnerability which exists in SAP Supplier Relationship Management (SAP SRM) solution, it is possible for a hacker to access restricted SAP transactions at runtime. This can lead to any or all of the following:

Manipulation of Business Logic resulting to inconsistent data states.
This may lead to violation of  regulatory compliance as vulnerability allows for unprivileged access to critical business logic.

Affected Releases

  • SAP SRM 7.01
  • SAP SRM 700
  • SAP SRM 600
  • SAP SRM 500

Available fix and Supported packages

  • SRM_SERVER | 550 | 550
  • SRM_SERVER | 600 | 600
  • SRM_SERVER | 700 | 700
  • SRM_SERVER | 701 | 701
  • SRM_SERVER 600 | SAPKIBKU06 |
  • SRM_SERVER 550 | SAPKIBKT17 |
  • SRM_SERVER 700 | SAPKIBKV08 |
  • SRM_SERVER 701 | SAPK-70102INSRMSRV |

Affected component

    SRM-BW
    SRM Analytics

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/1471265

TAGS

#SRM
#Supplier-Relationship-Management
#procurement
#E-Commerce
#Web
#business-to-business
#SAP-Business-to-Business-Procurement-BBP
#business-to-business
#e-business
#Ebusiness
#Internet
#EBP
#Enterprise-Buyer
#EnterpriseBuyer-professional-edition
#SRM_SERVER
#Securityvulnerability
#Dynamic-Function-call.