Skip links

Correcting buffer overflow in ABAP system call, SAP security note 1493516

Description

A malicious ABAP developer can exploit a buffer overflow in the SAP kernel and cause a work process to crash.

Available fix and Supported packages

  • KRNL32NUC | 6.40 | 6.40EX2
  • KRNL32NUC | 7.00 | 7.01
  • KRNL32NUC | 7.10 | 7.11
  • KRNL32UC | 6.40 | 6.40EX2
  • KRNL32UC | 7.00 | 7.01
  • KRNL32UC | 7.10 | 7.11
  • KRNL64NUC | 6.40 | 6.40EX2
  • KRNL64NUC | 7.00 | 7.01
  • KRNL64NUC | 7.10 | 7.11
  • KRNL64UC | 6.40 | 6.40EX2
  • KRNL64UC | 7.00 | 7.01
  • KRNL64UC | 7.10 | 7.11
  • SAP_BASIS | 720 | 730
  • KERNEL | 6.40 | 6.40
  • KERNEL | 7.00 | 7.01
  • KERNEL | 7.10 | 7.11
  • SAP KERNEL 6.40 32-BIT | SP343 | 000343
  • SAP KERNEL 6.40 32-BIT UNICODE | SP343 | 000343
  • SAP KERNEL 6.40 64-BIT | SP343 | 000343
  • SAP KERNEL 6.40 64-BIT UNICODE | SP343 | 000343
  • SAP KERNEL 6.40_EX2 32-BIT | SP343 | 000343
  • SAP KERNEL 6.40_EX2 32-BIT UC | SP343 | 000343
  • SAP KERNEL 6.40_EX2 64-BIT | SP343 | 000343
  • SAP KERNEL 6.40_EX2 64-BIT UC | SP343 | 000343
  • SAP KERNEL 7.00 32-BIT | SP268 | 000268
  • SAP KERNEL 7.00 32-BIT UNICODE | SP268 | 000268
  • SAP KERNEL 7.00 64-BIT | SP268 | 000268
  • SAP KERNEL 7.00 64-BIT UNICODE | SP268 | 000268
  • SAP KERNEL 7.01 32-BIT | SP107 | 000107
  • SAP KERNEL 7.01 32-BIT UNICODE | SP107 | 000107
  • SAP KERNEL 7.01 64-BIT | SP107 | 000107
  • SAP KERNEL 7.01 64-BIT UNICODE | SP107 | 000107
  • SAP KERNEL 7.10 32-BIT | SP213 | 000213
  • SAP KERNEL 7.10 32-BIT UNICODE | SP213 | 000213
  • SAP KERNEL 7.10 64-BIT | SP213 | 000213
  • SAP KERNEL 7.10 64-BIT UNICODE | SP213 | 000213

Affected component

    BC-CST-LL
    Low Level Layers

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/1493516

TAGS

#Buffer-overrun
#crash
#core