Skip links

Code injection vulnerability in SAP HANA Web-based Development Workbench, SAP security note 2153892

Description

SAP HANA Web-based Development Workbench contains code that permits attackers to use specially crafted inputs to modify database commands. This results in either the retrieval of additional information, or the modification of data persisted by the system.

CVSS Information
CVSS Base Score:  6.0 / 10
CVSS Base Vector:

AV : Access Vector (Related exploit range) Network (N)
AC : Access Complexity (Required attack complexity) Medium (M)
Au : Authentication (Level of authentication needed to exploit) Single (S)
C : Impact to Confidentiality Partial (P)
I  : Impact to Integrity Partial (P)
A : Impact to Availability Partial (P)

 SAP provides this CVSS base score as an estimate of the risk posed by the issue reported in this note. This estimate does not take into account your own system configuration or operational environment. It is not intended to replace any risk assessments you are advised to conduct when deciding on the applicability or priority of this SAP security note. For more information, see the FAQ section at https://support.sap.com/securitynotes.

Available fix and Supported packages

  • HDB | 1.00 | 1.00
  • SAP HANA DATABASE 1.00 | SP085 | 000003
  • SAP HANA DATABASE 1.00 | SP093 | 000000

Affected component

    HAN-WDE
    SAP Web IDE for Hana

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/2153892

TAGS

#Code-injection
#SAP-HANA&160-Web-based-Development-Workbench