Skip links

CVE-2019-0281 Cross-Site Scripting (XSS) vulnerability in SAPUI5 and OpenUI5, SAP security note 2756539

Description

OpenUI5 does not sufficiently encode user controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.

Some well-known impacts of XSS vulnerability are –

  • non-permanently deface or modify displayed content from a Web site
  • steal authentication information of the user, such as data relating to his or her current session
  • impersonate the user and access all information with the same rights as the target user 

Available fix and Supported packages

  • UISAPUI5_JAVA | 7.50 | 7.50
  • SAP_UI | 750 | 750
  • SAP_UI | 751 | 751
  • SAP_UI | 752 | 752
  • SAP_UI | 753 | 753
  • UI_700 | 200 | 200
  • XSAC_UI5_FESV3 | 1 | 1
  • XSAC_UI5_FESV4 | 1 | 1
  • XSAC_UI5_FESV5 | 1 | 1
  • SAPUI5 CLIENT RT AS JAVA 7.50 | SP013 | 000012
  • SAPUI5 CLIENT RT AS JAVA 7.50 | SP014 | 000003
  • SAPUI5 CLIENT RT AS JAVA 7.50 | SP015 | 000000
  • SAPUI5 FESV3 XSA 1 | SP044 | 000044
  • SAPUI5 FESV4 XSA 1 | SP052 | 000028
  • SAPUI5 FESV5 XSA 1 | SP060 | 000008

Affected component

    CA-UI5-CTR-ROD
    SAP UI5 Controls Rodopi team

CVSS

Score: 6.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/2756539

TAGS

#&65279-XSS
#DOM-based&160-XSS
#&160-CSS&65279
#&160-CVE-2019-0281&65279