Skip links

CVE-2020-6226 Cross-Site Scripting (XSS) vulnerabilities in SAP Business Objects Business Intelligence Platform (Web Intelligence HTML interface), SAP security note 2879132

Description

Cross site scripting

SAP BusinessObjects Business Intelligence Platform (Web Intelligence HTML interface) does not sufficiently encode user controlled inputs, resulting in Stored Cross-Site Scripting (XSS) vulnerability on different parameters. The individual CVSS scores and CVEs of the vulnerabilities can be found below.

1. Stored cross site scripting

    CVE-2020-6226

    CVSS Score: 5.4; CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

2. Stored cross site scripting

    CVE-2020-6231

    CVSS Score: 5.4; CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Some well-known impacts of XSS vulnerability are –

  • non-permanently deface or modify displayed content from a Web site
  • steal authentication information of the user, such as data relating to his or her current session
  • impersonate the user and access all information with the same rights as the target user 

Available fix and Supported packages

  • ENTERPRISE | 420 | 420
  • SBOP BI PLATFORM SERVERS 4.2 | SP006 | 001300
  • SBOP BI PLATFORM SERVERS 4.2 | SP007 | 000800
  • SBOP BI PLATFORM SERVERS 4.2 | SP008 | 000000

Affected component

    BI-RA-WBI-FE
    Front End/Client

CVSS

Score: 5.4
CVSS:/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/2879132

TAGS

#&65279-XSS
#stored-XSS
#CSS&65279
#&160-&160-WebI