Skip links

CVE-2020-6318 Code Injection vulnerability in SAP NetWeaver (ABAP Server) and ABAP Platform, SAP security note 2958563

Description

A Remote Code Execution vulnerability exists in the SAP NetWeaver (ABAP Server, up to release 7.40) and ABAP Platform (> release 7.40).

Because of this, an attacker can exploit these products potentially enabling to take complete control of the products, including viewing, changing, or deleting data by injecting code into the working memory which is subsequently executed by the application. It can also be used to cause a general fault in the product, causing the products to terminate.

Available fix and Supported packages

  • SAP_BW | 700 | 702
  • SAP_BW | 710 | 711
  • SAP_BW | 730 | 730
  • SAP_BW | 731 | 731
  • SAP_BW | 740 | 740
  • SAP_BW | 750 | 755
  • SAP_BW_VIRTUAL_COMP | 701 | 701
  • SAP_BW 700 | SAPKW70040 |
  • SAP_BW 701 | SAPKW70123 |
  • SAP_BW 702 | SAPKW70223 |
  • SAP_BW 730 | SAPKW73021 |
  • SAP_BW 752 | SAPK-75207INSAPBW |
  • SAP_BW 753 | SAPK-75305INSAPBW |
  • SAP_BW 754 | SAPK-75403INSAPBW |
  • SAP_BW 711 | SAPKW71121 |
  • | SAPK-S4CLOUD_2011_BW |
  • SAP_BW 731 | SAPKW73128 |
  • SAP_BW 740 | SAPKW74025 |
  • SAP_BW 755 | SAPK-75501INSAPBW |
  • SAP_BW 750 | SAPK-75020INSAPBW |
  • SAP_BW 751 | SAPK-75112INSAPBW |
  • SAP_BW_VIRTUAL_COMP 701 | SAPK-70166INVCBWTECH |

Affected component

    BW-SYS-DB-SYB
    BW on Adaptive Server Enterprise

CVSS

Score: 9.1
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/2958563

TAGS

#Command-Injection
#OS-command-injection
#SQL-injection
#&160-CVE-2020-6318