Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

CVE-2019-0275 Cross-Site Scripting (XSS) Vulnerability in SAP NW SAML 1.1 SSO Demo App, SAP security note 2689925

Description

SAML 1.1 SSO Demo Application in SAP NetWeaver Java Application Server does not sufficiently encode user-controlled inputs, which results in cross-site scripting (XSS) vulnerability.

Some well-known impacts of XSS vulnerability are the following:

  • Temporarily deface or modify displayed content on a website.
  • Steal authentication information of the user such as data related to his or her current session.
  • Impersonate the user and access all information with the same rights as the target user.

Available fix and Supported packages

  • J2EE-APPS | 7.10 | 7.11
  • J2EE-APPS | 7.20 | 7.20
  • J2EE-APPS | 7.30 | 7.30
  • J2EE-APPS | 7.31 | 7.31
  • J2EE-APPS | 7.40 | 7.40
  • J2EE-APPS | 7.50 | 7.50
  • J2EE ENGINE APPLICATIONS 7.10 | SP020 | 000004
  • J2EE ENGINE APPLICATIONS 7.10 | SP021 | 000004
  • J2EE ENGINE APPLICATIONS 7.10 | SP022 | 000004
  • J2EE ENGINE APPLICATIONS 7.10 | SP023 | 000003
  • J2EE ENGINE APPLICATIONS 7.10 | SP024 | 000000
  • J2EE ENGINE APPLICATIONS 7.11 | SP015 | 000004
  • J2EE ENGINE APPLICATIONS 7.11 | SP016 | 000006
  • J2EE ENGINE APPLICATIONS 7.11 | SP017 | 000003
  • J2EE ENGINE APPLICATIONS 7.11 | SP018 | 000002
  • J2EE ENGINE APPLICATIONS 7.11 | SP019 | 000000
  • J2EE ENGINE APPLICATIONS 7.20 | SP009 | 000028
  • J2EE ENGINE APPLICATIONS 7.30 | SP016 | 000014
  • J2EE ENGINE APPLICATIONS 7.30 | SP017 | 000009
  • J2EE ENGINE APPLICATIONS 7.30 | SP018 | 000008
  • J2EE ENGINE APPLICATIONS 7.30 | SP019 | 000001
  • J2EE ENGINE APPLICATIONS 7.30 | SP020 | 000000
  • J2EE ENGINE APPLICATIONS 7.31 | SP020 | 000016
  • J2EE ENGINE APPLICATIONS 7.31 | SP021 | 000010
  • J2EE ENGINE APPLICATIONS 7.31 | SP022 | 000008
  • J2EE ENGINE APPLICATIONS 7.31 | SP023 | 000002

Affected component

    BC-JAS-SEC-LGN
    Logon, SSO

CVSS

Score: 7.6
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:L

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/2689925

TAGS

#&65279-XSS
#stored-XSS
#reflected-XSS
#CSS&65279
#&160-CVE-2019-0275

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,