Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Missing authorization check in core service, SAP security note 1682613

Description

An unauthenticated user can use functions of file service to which access should be restricted. This may result in an escalation of privileges.

CVSS Information

CVSS Base Score: 10
CVSS Base Vector: AV:N/AC:L/AU:N/C:C/I:C/A:C

SAP provides this CVSS base score as an estimate of the risk posed by the issue reported in this note. This estimate does not take into account your own system configuration or operational environment. It is not intended to replace any risk assessments you are advised to conduct when deciding on the applicability or priority of this SAP security note. For more information, see the FAQ section at https://service.sap.com/securitynotes/

Available fix and Supported packages

  • SAP-JEE | 6.40 | 6.40
  • SAP-JEECOR | 7.00 | 7.00
  • SAP-JEECOR | 6.40 | 6.40
  • SAP-JEECOR | 7.01 | 7.02
  • SERVERCORE | 7.10 | 7.10
  • SERVERCORE | 7.11 | 7.11
  • SERVERCORE | 7.20 | 7.20
  • SERVERCORE | 7.30 | 7.30
  • SERVERCORE | 7.31 | 7.31
  • J2EE ENGINE SERVERCORE 7.10 | SP011 | 000014
  • J2EE ENGINE SERVERCORE 7.10 | SP012 | 000015
  • J2EE ENGINE SERVERCORE 7.10 | SP013 | 000006
  • J2EE ENGINE SERVERCORE 7.10 | SP014 | 000002
  • J2EE ENGINE SERVERCORE 7.10 | SP015 | 000000
  • J2EE ENGINE SERVERCORE 7.11 | SP006 | 000032
  • J2EE ENGINE SERVERCORE 7.11 | SP007 | 000014
  • J2EE ENGINE SERVERCORE 7.11 | SP008 | 000009
  • J2EE ENGINE SERVERCORE 7.11 | SP009 | 000002
  • J2EE ENGINE SERVERCORE 7.11 | SP010 | 000000
  • J2EE ENGINE SERVERCORE 7.20 | SP004 | 000045
  • J2EE ENGINE SERVERCORE 7.20 | SP005 | 000022
  • J2EE ENGINE SERVERCORE 7.20 | SP006 | 000011
  • J2EE ENGINE SERVERCORE 7.20 | SP007 | 000001
  • J2EE ENGINE SERVERCORE 7.20 | SP008 | 000000
  • J2EE ENGINE SERVERCORE 7.30 | SP001 | 000015
  • J2EE ENGINE SERVERCORE 7.30 | SP002 | 000021
  • J2EE ENGINE SERVERCORE 7.30 | SP003 | 000019
  • J2EE ENGINE SERVERCORE 7.30 | SP004 | 000010
  • J2EE ENGINE SERVERCORE 7.30 | SP005 | 000012

Affected component

    BC-JAS-COR
    Enterprise Runtime, Core J2EE Framework

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1682613

TAGS

#Authorization
#authorization-check
#file-service

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,