Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Wrong setup of security policy profile when creating a user, SAP security note 1672344

Description

When creating and managing users concerning security policy profiles there might be set incorrect (predefined) security policy profile to the user. The issue can occur in the following scenarios:
1. Creating a user in useradmin application.
2. Creating a user with UME API.
3. Creating a user in self registration scenario.
4. Managing user data in useradmin application or UME API.

Available fix and Supported packages

  • SAP-JEECOR | 7.00 | 7.00
  • SAP-JEECOR | 7.01 | 7.02
  • SERVERCORE | 7.10 | 7.10
  • SERVERCORE | 7.11 | 7.11
  • SERVERCORE | 7.20 | 7.20
  • SERVERCORE | 7.30 | 7.30
  • SERVERCORE | 7.31 | 7.31
  • J2EE ENGINE SERVERCORE 7.11 | SP006 | 000030
  • J2EE ENGINE SERVERCORE 7.11 | SP007 | 000013
  • J2EE ENGINE SERVERCORE 7.11 | SP008 | 000007
  • J2EE ENGINE SERVERCORE 7.11 | SP009 | 000002
  • J2EE ENGINE SERVERCORE 7.11 | SP010 | 000000
  • J2EE ENGINE SERVERCORE 7.20 | SP004 | 000043
  • J2EE ENGINE SERVERCORE 7.20 | SP005 | 000020
  • J2EE ENGINE SERVERCORE 7.20 | SP006 | 000008
  • J2EE ENGINE SERVERCORE 7.20 | SP007 | 000001
  • J2EE ENGINE SERVERCORE 7.20 | SP008 | 000000
  • J2EE ENGINE SERVERCORE 7.30 | SP001 | 000014
  • J2EE ENGINE SERVERCORE 7.30 | SP002 | 000019
  • J2EE ENGINE SERVERCORE 7.30 | SP003 | 000016
  • J2EE ENGINE SERVERCORE 7.30 | SP004 | 000008
  • J2EE ENGINE SERVERCORE 7.30 | SP005 | 000008
  • J2EE ENGINE SERVERCORE 7.30 | SP007 | 000000
  • J2EE ENGINE SERVERCORE 7.30 | SP008 | 000000
  • J2EE ENGINE SERVERCORE 7.31 | SP001 | 000006
  • J2EE ENGINE SERVERCORE 7.31 | SP002 | 000001
  • J2EE ENGINE SERVERCORE 7.31 | SP003 | 000000

Affected component

    BC-JAS-SEC-UME
    User Management Engine

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1672344

TAGS

#UME
#user-security-policy
#self-registration
#create-user
#useradmin

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,

Protect Your SAP with RedRays Security Platform

Explore the Power of Our Scanner with an Interactive Prototype Below