Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Missing XML Validation vulnerability in SAP Netweaver Visual Composer, SAP security note 2347439

Description

A malicious user can modify an XML-based request to include XML content that is then parsed locally.
This could allow a malicious user to perform a denial of service (DoS) on the parsing system, or disclose local data that is then returned in the response to the malicious request, or access further network-located resources that are accessible from the parsing system.

Visual Composer flex.broker does not sufficiently validate an XML document accepted from an untrusted source.

Some well-known impacts of Missing XML Validation vulnerability are –

  • arbitrary files retrieval from the server
  • denial-of-service conditions in successful exploits

CVSS Information

CVSS v3 Base Score: 6.4 / 10
CVSS v3 Base Vector:

AV : Attack Vector (Related exploit range)

Network (N)

AC : Attack Complexity (Required attack complexity)

High (H)

PR : Privileges Required (Level of privileges needed to exploit)

Low (L)

UI : User Interaction (Required user participation)

None (N)

S : Scope (Change in scope due to impact caused to components beyond the vulnerable component)

Unchanged (U)

C : Impact to Confidentiality

Low (L)

I : Impact to Integrity

Low (L)

A : Impact to Availability

High (H)

SAP provides this CVSS v3 base score as an estimate of the risk posed by the issue reported in this note. This estimate does not take into account your own system configuration or operational environment. It is not intended to replace any risk assessments you are advised to conduct when deciding on the applicability or priority of this SAP security note. For more information, see the FAQ section at https://support.sap.com/securitynotes

Available fix and Supported packages

  • VCFRAMEWORK | 7.00 | 7.02
  • VC70RUNTIME | 7.30 | 7.30
  • VC70RUNTIME | 7.31 | 7.31
  • VC70RUNTIME | 7.40 | 7.40
  • VISUAL COMPOSER 7.0 RT 7.30 | SP016 | 000001
  • VISUAL COMPOSER 7.0 RT 7.30 | SP017 | 000000
  • VISUAL COMPOSER 7.0 RT 7.31 | SP018 | 000003
  • VISUAL COMPOSER 7.0 RT 7.31 | SP019 | 000002
  • VISUAL COMPOSER 7.0 RT 7.31 | SP020 | 000000
  • VISUAL COMPOSER 7.0 RT 7.40 | SP013 | 000003
  • VISUAL COMPOSER 7.0 RT 7.40 | SP014 | 000002
  • VISUAL COMPOSER 7.0 RT 7.40 | SP015 | 000000
  • VISUAL COMPOSER FRAMEWORK 7.00 | SP033 | 000002
  • VISUAL COMPOSER FRAMEWORK 7.00 | SP034 | 000000
  • VISUAL COMPOSER FRAMEWORK 7.01 | SP018 | 000002
  • VISUAL COMPOSER FRAMEWORK 7.01 | SP019 | 000000
  • VISUAL COMPOSER FRAMEWORK 7.02 | SP018 | 000002
  • VISUAL COMPOSER FRAMEWORK 7.02 | SP019 | 000000

Affected component

    EP-VC
    Visual Composer

CVSS

Score: 0

Exploit

Exploit is not available.
For detailed information please contact the mail [email protected]

URL

https://launchpad.support.sap.com/#/notes/2347439

TAGS

#XXE
#XML-eXternal-Entity
#information-disclosure
#denial-of-service
#DoS

More to explorer