Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Code injection vulnerability in WD ABAP ALV, SAP security note 1612690

Description

WD ABAP ALV contains code that permits the execution of arbitrary program code of the user’s choice.

A malicious user can therefore control the behavior of the system, or can potentially escalate privileges by executing malicious code, without having their own legitimate credentials.

Available fix and Supported packages

  • SAP_BASIS | 711 | 720
  • SAP_BASIS | 800 | 802
  • SAP_BASIS 711 | SAPKB71108 |
  • SAP_BASIS 720 | SAPKB72006 |

Affected component

    BC-WD-CMP-ALV-ABA
    ALV for ABAP

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1612690

TAGS

#Backdoor
#injection
#run
#credentials
#WD-ABAP-ALV

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,

Protect Your SAP with RedRays Security Platform

Explore the Power of Our Scanner with an Interactive Prototype Below