Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

CVE-2019-0262 Cross-Site Scripting (XSS) vulnerability in WebIntelligence BILaunchPad, SAP security note 2696714

Description

WebIntelligence BILaunchPad does not sufficiently encode user controlled inputs in generated HTML reports, resulting in Cross-Site Scripting (XSS) vulnerability.

Some well-known impacts of XSS vulnerability are –

  • non-permanently deface or modify displayed content from a Web site
  • steal authentication information of the user, such as data relating to his or her current session
  • impersonate the user and access all information with the same rights as the target user 

Available fix and Supported packages

  • ENTERPRISE | 410 | 410
  • ENTERPRISE | 420 | 420
  • SBOP BI PLATFORM SERVERS 4.1 | SP010 | 000011
  • SBOP BI PLATFORM SERVERS 4.1 | SP011 | 000600
  • SBOP BI PLATFORM SERVERS 4.1 | SP012 | 000000
  • SBOP BI PLATFORM SERVERS 4.2 | SP004 | 000012
  • SBOP BI PLATFORM SERVERS 4.2 | SP005 | 000700
  • SBOP BI PLATFORM SERVERS 4.2 | SP006 | 000300
  • SBOP BI PLATFORM SERVERS 4.2 | SP007 | 000000

Affected component

    BI-RA-WBI-SDK
    Software Developement Kit

CVSS

Score: 4.1
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/2696714

TAGS

#&65279-XSS
#stored-XSS
#reflected-XSS
#CSS
#&160-CVE-2019-0262

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,