Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Incorrect authorization check in File Adapter, SAP security note 1578579

Description

File adapter incorrectly accepts SSL Connection.

Available fix and Supported packages

  • MESSAGING | 7.10 | 7.11
  • MESSAGING | 7.30 | 7.30
  • MESSAGING | 7.31 | 7.31
  • SAP-XIAFC | 7.00 | 7.02
  • MESSAGING SYSTEM SERVICE 7.10 | SP013 | 000000
  • MESSAGING SYSTEM SERVICE 7.11 | SP008 | 000000
  • MESSAGING SYSTEM SERVICE 7.30 | SP000 | 000001
  • MESSAGING SYSTEM SERVICE 7.30 | SP001 | 000006
  • MESSAGING SYSTEM SERVICE 7.30 | SP002 | 000007
  • MESSAGING SYSTEM SERVICE 7.30 | SP003 | 000003
  • MESSAGING SYSTEM SERVICE 7.30 | SP004 | 000001
  • MESSAGING SYSTEM SERVICE 7.30 | SP005 | 000000
  • MESSAGING SYSTEM SERVICE 7.31 | SP001 | 000000
  • XI ADAPTER FRAMEWORK CORE 7.00 | SP025 | 000000
  • XI ADAPTER FRAMEWORK CORE 7.01 | SP010 | 000000
  • XI ADAPTER FRAMEWORK CORE 7.02 | SP009 | 000000

Affected component

    BC-XI-CON-AFW-SEC
    Security

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1578579

TAGS

#Authentication
#authentication-check
#File-Adapter
#SSL
#Certificate

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,

Protect Your SAP with RedRays Security Platform

Explore the Power of Our Scanner with an Interactive Prototype Below