Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

KM security improvement for SSL Client Certificate checks, SAP security note 1499704

Description

In some cases the user might not be properly validated against client certificate when using SSL communication.

Available fix and Supported packages

  • EPBC2 | 7.00 | 7.02
  • KMC-CM | 7.00 | 7.02
  • KMC-CM | 7.30 | 7.30
  • KMC-CM | 7.31 | 7.31
  • EP-CM | 6.0_640 | 6.0_640
  • CM+COLLABORATION 6.0_640 | SP026 | 000007
  • CM+COLLABORATION 6.0_640 | SP027 | 000004
  • CM+COLLABORATION 6.0_640 | SP028 | 000001
  • CM+COLLABORATION 6.0_640 | SP029 | 000000
  • KMC CONTENT MANAGEMENT 7.00 | SP021 | 000002
  • KMC CONTENT MANAGEMENT 7.00 | SP022 | 000001
  • KMC CONTENT MANAGEMENT 7.00 | SP023 | 000001
  • KMC CONTENT MANAGEMENT 7.00 | SP024 | 000000
  • KMC CONTENT MANAGEMENT 7.01 | SP006 | 000006
  • KMC CONTENT MANAGEMENT 7.01 | SP007 | 000001
  • KMC CONTENT MANAGEMENT 7.01 | SP008 | 000000
  • KMC CONTENT MANAGEMENT 7.02 | SP004 | 000003
  • KMC CONTENT MANAGEMENT 7.02 | SP005 | 000002
  • KMC CONTENT MANAGEMENT 7.02 | SP006 | 000005
  • KMC CONTENT MANAGEMENT 7.02 | SP007 | 000000
  • KMC CONTENT MANAGEMENT 7.30 | SP001 | 000000
  • KMC CONTENT MANAGEMENT 7.31 | SP001 | 000000
  • PORTAL FRAMEWORK 7.00 | SP021 | 000012
  • PORTAL FRAMEWORK 7.00 | SP022 | 000007
  • PORTAL FRAMEWORK 7.00 | SP023 | 000000

Affected component

    EP-KM-CM
    Content Management

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1499704

TAGS

#

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,

Protect Your SAP with RedRays Security Platform

Explore the Power of Our Scanner with an Interactive Prototype Below