Skip links
Arpine Maghakyan

Arpine Maghakyan

Security Researcher of RedRays.

Potential disclosure of persisted data in CRM-MD-PCT, SAP security note 1594125

Description

A malicious user can exploit the CRM product catalog application and use specially crafted inputs to modify database commands, resulting in the retrieval of additional information persisted by the system.

Available fix and Supported packages

  • BBPCRM | 400 | 400
  • BBPCRM | 500 | 500
  • BBPCRM | 520 | 520
  • BBPCRM | 600 | 600
  • BBPCRM | 700 | 700
  • BBPCRM | 701 | 701
  • BBPCRM 400 | SAPKU40018 |
  • BBPCRM 520 | SAPKU52011 |
  • BBPCRM 500 | SAPKU50019 |
  • BBPCRM 600 | SAPKU60010 |
  • BBPCRM 700 | SAPKU70010 |
  • BBPCRM 701 | SAPKU70105 |

Affected component

    CRM-MD-PCT
    Product Catalog

CVSS

Score: 0

Exploit

Detailed vulnerability information added to RedRays Security Platform. Contact [email protected] for details.

URL

https://launchpad.support.sap.com/#/notes/1594125

TAGS

#SQL-injection
#database
#CRM-MD-PCT
#COM_PCAT_FOREIGNKEYCHECK
#iv_tablename
#iv_fieldname
#iv_fieldvalue

More to explorer

SAP Cloud Connector Certificate Validation Issue

Date of Release: February 13, 2024 Advisory ID: CVE-2024-25642 Affected Software: SAP Cloud Connector Versions Affected: 2.15.0 to 2.16.1 Vulnerability Summary:A critical vulnerability,

Protect Your SAP with RedRays Security Platform

Explore the Power of Our Scanner with an Interactive Prototype Below